Jump to content
Patrick

[Stable] OSBot 2.6.7

Recommended Posts

  • Developer

Hey,

 

A new stable release due to the new settings interface and break issues.

 

API CHANGES:
- Added Settings#BasicSettingsTab, Settings#AllSettingsTab, Settings#getAllSettingsWidget(), Settings#openAllSettingsWidget(), Settings#isAllSettingsWidgetVisible(), Settings#getCurrentAllSettingsTab(), Settings#getCurrentBasicSettingsTab(), Settings#open(BasicSettingsTab), Settings#getBasicSettingsTabWidget(BasicSettingsTab) & Settings#getAllSettingsTabWidget(AllSettingsTab)
- Added Widgets#getWidgetContainingAction(rootId, actions) and Widgets#getWidgetContainingAction(actions)

FIXES:
- Breaks work again.

WEB WALKER:
- The webwalker will now terminate when the user is logged out.

MISC:
- Minor bug fixes.
 

 

- The OSBot Team

  • Like 8
Link to post
1 minute ago, Patrick said:

You might be running an older version, a script that override the break manager or have some incorrect settings. Scripters and users have confirmed it's working now.

I’ll have another look now, I don’t use script breaks, always use the osbot break manager. I have also updated to the most recent version. Cheers brother.

Link to post
18 minutes ago, Patrick said:

You might be running an older version, a script that override the break manager or have some incorrect settings. Scripters and users have confirmed it's working now.

Updated, restarted multiple times. Still wasn’t working. So decided to delete osbot and re-download. Break manager is now working. 
 

thanks

Link to post
5 hours ago, Wishy said:

@Patrick

Webwalker bug ive found in the last few updates.

Want the script to walk the black line. Have all the correct X and Y coordinates

Instead webwalker will walk Blue line

https://prnt.sc/vucag8

This has been like this since 2016. 

The wilderness ditch area has always been buggy. I suggest walking to the south of the ditch, interacting with the object and then using webwalker after youre north of it

  • Sad 1
Link to post
6 hours ago, Wishy said:

@Patrick

Webwalker bug ive found in the last few updates.

Want the script to walk the black line. Have all the correct X and Y coordinates

Instead webwalker will walk Blue line

https://prnt.sc/vucag8

The webwalker doesn't use the shortest path, it generates another path every time :)
If you want to walk the same path don't use the webwalker.

18 minutes ago, Juggles said:

This has been like this since 2016. 

The wilderness ditch area has always been buggy. I suggest walking to the south of the ditch, interacting with the object and then using webwalker after youre north of it

True, but ww doesn't always use shortest path either.
even with simplepaths on

  • Heart 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...