Jump to content
ez11

Mirrormode crashes when trying to connect with Runelite

Recommended Posts

@MGI

Client version: v5.9.192 (supposed to be 6.0?)

Java version: java version "1.8.0_241"
Java(TM) SE Runtime Environment (build 1.8.0_241-b07)
Java HotSpot(TM) 64-Bit Server VM (build 25.241-b07, mixed mode)

 

Opening trying to connect osbot to a runelite client crashes the runelite client after a few sec and produces the error seen below:

[DEBUG][Bot #1][12/03 05:31:57 PM]: Initializing mirror client bot...
[INFO][12/03 05:31:57 PM]: Started bot #1
Created temp copy of nattach_64.dll as C:\Users\Stefan\AppData\Local\Temp\wrwr3008764690954625013.dll
Created temp copy of stream_64.dll as C:\Users\Stefan\AppData\Local\Temp\wee6853939873995132694.dll
Created temp copy of stream_32.dll as C:\Users\Stefan\AppData\Local\Temp\qww1738742892720662449.dll
Created temp copy of stream_64.dll as C:\Users\Stefan\AppData\Local\Temp\erre48495078837714222.dll
java.io.IOException: VirtualAllocEx failed: ERR(5)
        at client.nat.nattach.WindowsVirtualMachine.M9(Native Method)
        at client.nat.nattach.WindowsVirtualMachine.srr(Unknown Source)
        at client.dB.km(Unknown Source)
        at client.dUK.vj(Unknown Source)
        at client.yr.lmd(Unknown Source)
        at client.uc.rqse(Unknown Source)
        at client.emu.Tm.run(Unknown Source)

 

Running the newest 64bit Runelite client and following the instructions in the release post (moving runelite directory to desktop).

Also tested having runelite installed in the default directory (users/appdata/local) aswell as installing runelite in the same directory as osbot (users) without success.

I have seen multiple others with the same issue I have including multiple people in the release post.

I talked with @Patrick who seems to have the exact same runelite/java version aswell has having runelite in the same directory as me and it works for him somehow.

Link to post
Share on other sites
On 12/3/2020 at 10:01 AM, Eliot said:

@MGImirror mode is totally broken with Runelite, nobody I've talked to can get it to work. Please post an update and fix it.

 

@Maxi@Zach @Patrick

Three months later, still broken for me. It also can't mirror OpenOSRS, any plans to support that?

  • Like 2
Link to post
Share on other sites
On 2/10/2021 at 12:55 PM, Eliot said:

Three months later, still broken for me. It also can't mirror OpenOSRS, any plans to support that?

i had the same issue and unistalled runelite and installed the 32 bit version of runelite and works fine now

 

EDIT: nvm it only worked once now its crashing again

Edited by wingtangtoe
didnt owrk
Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...