Jump to content
Patrick

[Stable] OSBot 2.6.5

Recommended Posts

  • Developer

Hey,

 

This release has some nice fixes and new features.

 

API CHANGES:
- WalkingEvent(Area) will now check for completion by checking if the player is in the area.
- Added MoveMouseEvent#isNewMouse() to check if the user has the new mouse enabled.

FIXES:
- Scrolling in the account tab works again.
- Fixed break manager starting the breaks too early or using breaks with 0 values.
- Fixed world hopping to target worlds.
- Fixed a bug causing the 400 world hopper patch to break.
- Fixed an issue where Store#buy & Store#sell would get stuck in an infinite loop.
- Fixed Bank#getItemCountForTab() sometimes throwing errors.
- Fixed a couple NPEs.

WEB WALKER:

- Fixed a couple invalid links.

MISC:
- Hovering the account name in the account tab will display the full name.
- Minor bug fixes.
 

- The OSBot Team

  • Like 13
  • Heart 2
Link to post

@Patrick

Break manager is still logging out and back in any time a script with break settings is started. I asked previously about this and we were told that it was incorrect break settings. I asked for some documentation about the new breaking system as it is not clear what we are doing wrong ( many people having this issue). This is my current break settings:breaks.png

also I have asked several times, has the option to stop botting after break been removed completely? 

  • Like 1
Link to post

@Patrick
can u make breaks stay enable for every launched client?
on each new client i have to manually turn on breaks, if it is done after automatic acc login too late, the breaks don't work. In the old client breaks were always enabled after startup.
with lots of bots it's a pain after auto start farm and check every client on every server every time when i need to restart farm...

i post it in 2.6.4 and other ppl to but still the same problem 

Edited by ukasz
  • Like 1
Link to post
  • Developer
22 hours ago, botimusprime said:

@Patrick

Break manager is still logging out and back in any time a script with break settings is started. I asked previously about this and we were told that it was incorrect break settings. I asked for some documentation about the new breaking system as it is not clear what we are doing wrong ( many people having this issue). This is my current break settings:breaks.png

also I have asked several times, has the option to stop botting after break been removed completely? 

I'll see if I can add the option back in.

Your settings are looking correct, I'll use them and see if I also encounter any issues.

Edit: added the option back in for next release.

19 hours ago, ukasz said:

@Patrick
can u make breaks stay enable for every launched client?
on each new client i have to manually turn on breaks, if it is done after automatic acc login too late, the breaks don't work. In the old client breaks were always enabled after startup.
with lots of bots it's a pain after auto start farm and check every client on every server every time when i need to restart farm...

i post it in 2.6.4 and other ppl to but still the same problem 

 

19 hours ago, Gunman said:

Pat, my suggestion for the above issue is make a default break option so on start up it will automatically use that break profile with the default setting checked. Or/and add the ability to set break settings in cli args.

 

6 hours ago, maze1 said:

HOW COME THE BREAKS ARE STILL REQUIRED TO BE ACTIVATED BY HAND ON EVERY GOD DAMN CLIENT!!!??

I'll make the breaks enabled option save and load when you restart the client. I'll also add it to the cli argument in case you want to use it via that ways.

Edit: I've added both, will be available in the next release.

  • Like 3
Link to post
14 hours ago, Patrick said:

I'll see if I can add the option back in.

Your settings are looking correct, I'll use them and see if I also encounter any issues.

Edit: added the option back in for next release.

 

 

I'll make the breaks enabled option save and load when you restart the client. I'll also add it to the cli argument in case you want to use it via that ways.

Edit: I've added both, will be available in the next release.

Hey @PatrickAlso having the same issue like botismusprime. Hoping you can help with break settings.

Edited by Banes
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...