Jump to content
Lemons

Fixing DPI issues with Windows 8.1/10 (OSBot window is too small issue)

Recommended Posts

I know this issue crops up from time to time, I'm here with a way to fix it :) Thanks bot2max for letting me figure this out on his windows 10 tablet.

Compatibility method for Windows 10 ONLY

Spoiler

 

Step 1 - Open OSBot and the Task Manager, right-click "Java(TM) Platform SE Binary (32 bit)" and select "Open File Location"

jIPcVpY.png

Step 2 - Right-Click the selected file and select Properties

5zQobEr.png

Step 3 - Go to Compatibility tab, and check "Disable display scaling on High DPI settings"

TjVcjIb.png

Step 4 - Restart OSBot

Manifest hack method (WARNING: This ONLY works on Windows 8.1/10.)

Spoiler

 

If you are on 7 or 8, you're SOL, this guide will not work and cause issues with your setup.

 

Now that is out of the way, lets continue on. Basically, the issue is java is a "dpi aware" application, at least according to windows. As we can see, this is not the case as its microscopic when you launch it on higher DPIs. So, we need to tell windows that java is not in fact dpi aware.

 

Step 1 - Downloading Resource Hacker

Download Resource hacker from http://www.angusj.com/resourcehacker/. This is a free program that allows us to change the manifest of programs, which is exactly what we need. Get the "Portable Zip file" version, as we only need this briefly.

 

Step 2 - Opening Resource Hacker

Once downloaded extract the application to a new folder. Then right-click "Resource Hacker.exe" file (the exe part is prob hidden, should have an icon with RH in blue) and choose "Run as administrator".

dVkpz10.png

 

Step 3 - Using Resource Hacker

You should now have the Resource Hacker window open. Now click the open file button (shown below).

WNT1ywY.png

 

 

Then go to "C:\Program Files\Java", or "C:\Program Files (x86)\Java\" if you installed x86 on a 64-bit system. In here, you should see something resembling either "jre1.8.x_xx" or "jdk1.8.x_xx", if you have multiple you'll need to determine which is being used by OSBot.

 

Step 3.1 - Determine which JRE/JDK we need to edit

Generally, its the newest, else if you're having troubles, click start and type "cmd", which should give you the option for a command prompt. Inside the command prompt, type "java -version" and it should output something like:

 

Pl2iHMc.png

 

The "1.8.0_65" is what your looking for, and would be the "jre1.8.0_65" or "jdk1.8.0_65" folder.

 

Step 4 - Backup your shit

Now, were jumping off track for a second, but this is important when editting any system/executables. We wanna back them up incase we get in a jam. So, now that we know which JRE/JDK we are using, open Windows Explorer (aka the file manager), and go to that folder (something like C:\Program Files\Java\jre1.8.x_xx\ or C:\Program Files (x86)\Java\jre1.8.x_xx\), and go into its "bin" folder. Here, you should see java.exe and javaw.exe. Copy/paste both, they should become "java - Copy.exe" and "javaw - Copy.exe", which is good. Name them w/e you want, but we just want a copy in case things go south.

 

Step 5 - Editting the manifest

Now we know which JRE/JDK we are using, we need to go into the "bin" folder of the JRE/JDK. The full file path should look something like:

 

"C:\Program Files\Java\jre1.8.x_xx\bin\" or "C:\Program Files (x86)\Java\jre1.8.x_xx\bin\"

 

In here, should be a file called "java.exe", which is the main java executable. Select it and open it in resource editor. Now you should see:

 

EHqMFeF.png

 

Now, expand the Manifest tree and select "1 : 0", which should be the only item in this tree. Now you should see the window update with some manifest XML, which looks like:

 

F9dz4WV.png

 

Then, scroll this until you see something that looks like:

 

PspjOlf.png

 

Basically, your looking for 


<dpiAware>true</dpiAware>

then you'll want to change this to


<dpiAware>false</dpiAware>

Once you are done with this edit, click the green play button

 

O4GwCFD.png

 

Then click the save button

 

JY4Dnxq.png

 

Now, repeat this step, except replace "java.exe" with "javaw.exe". Once you are done editting both, go and run OSBot and it should be sized so it looks normal on your PC.

 

 

Closing Notes

I hope this helps most of you, if not feel free to contact me (check my profile or message me on here), and I can prob help if you run into issues. I personally have not had this issue (72 dpi win 7 nub) but I can see how this would be a huge annoyance.

 

PS: If you notice any typos/issues please point em out. I wouldn't say I'm sober atm so I can see there being issues I missed :p

PSS: Sorry if this has been posted before, or if there is an easier fix. Let me know and I'll remove/edit this post.

Edited by Lemons
  • Like 9
Link to comment
Share on other sites

Not sure why, but this doesn't seem to work for me. Edited both lines of config in both files, still OSBot boots up in too small of a window.

 

​The only thing that seems to help is running OSBot in low-resource mode through the command line, but that's just a stopgap measure so I can actually read the bot config menus. Any other known fixes out there?

 

Thanks guys!

Link to comment
Share on other sites

On 2/24/2019 at 4:55 PM, Slamminsam45 said:

When I open the file location the first picture is what pops up, so then I clicked on change high dpi settings and the second picture is what came up after that... what should I do now? I've tried both options on the second picture and nothing has worked.

OSBot1.PNG

OSBot2.PNG

Same for me, anyone?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...