Jump to content

Trying to typeString throws and error

Recommended Posts

Hello! So whenever I try to type a string to the keyboard I get this error.

getKeyboard().typeString("250", true);


[ERROR][Bot #1][07/31 02:25:53 PM]: Error in script executor!
    at core.Main.onLoop(Main.java:386)
    at org.osbot.rs07.event.ScriptExecutor$InternalExecutor.run(kl:223)
    at java.lang.Thread.run(Unknown Source)


I've tried keyboard.typeString() and getKeyboard().typeString() but nothing seems to be working. Anyone got any ideas?

Link to comment
Share on other sites

4 hours ago, Khaleesi said:

There is a nullpointer exception on something else ... so you must null check?
Show more of your code? :)

Core.Main line 386?

Managed to figure it out. Actually just moved to a different way. This was part of my GE script and sellItem wasnt working then I realized Im getting the same error and realized I had a capital on an Item name. Thanks for you guy's help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...