No worries - what I meant about switch statements was as follows: While it may work to lay the code out as you have done in your onLoop, it might lead to some unexpected results since it may execute more than one thing per loop of the onLoop. Here's the correct (...or traditional...) way to use a switch statement:
switch (getState()) {
/* ... */
case BANKING:
break;
case RETURN_FROM_BANK:
break;
case GO_TO_BANK:
break;
/* ... */
default:
break;
}
____________________________
As for using enums in this way to organise your code, I think it's a great way to separate the function of your code (i.e the interaction code, walking, etc) from the logic of your code (the checks, assertions etc). While plain if/else statements in your onLoop works just fine too, it can get quite overwhelming for larger projects.
It is important to note however that the difference between these solutions is purely aesthetic: neither solutions offer any additional functionality. As you progress with scripting and java in general, you will learn about inheritance, encapsulation, and other key object oriented concepts (alongside some common design patterns) which you can apply to your code to make it 'do more for less'.
Best
Apa