Jump to content
LeeHoffman

Add custom scripts?

Recommended Posts

When you have a script created that is in .jar format you would add it to your script folder here C:\Users\YOURPCNAME\OSBot\Scripts, then open osbot and you should see the script there if you've set it up properly.

Edit: little late on my post lol, but gl.

Edited by DeadPk3r
Link to comment
Share on other sites

If your files are .java, then they need to be compiled to .class.

If your files are .class, then they need to be put into OSBot's script folder (C:/users/you/osbot/scripts).

If you've compiled and packaged your script as a .jar, then that needs to go in there as well.

Also, if you're using Eclipse, check this out:

 

  • Like 1
Link to comment
Share on other sites

I have it in Jar form in C:\Users\***\OSBot\Scripts. I was forced to update eclipse and had it working before hand. It no longer shows up in the scripts even though an executable jar file is in the scripts folder. So I deleted everything to do with eclipse and osbot then reinstalled it. I've followed the setting up eclipse and created a new project but it still doesn't work, any thoughts on what the problem is would be greatly appreciated.

Link to comment
Share on other sites

2 hours ago, Everonimo said:

I have it in Jar form in C:\Users\***\OSBot\Scripts. I was forced to update eclipse and had it working before hand. It no longer shows up in the scripts even though an executable jar file is in the scripts folder. So I deleted everything to do with eclipse and osbot then reinstalled it. I've followed the setting up eclipse and created a new project but it still doesn't work, any thoughts on what the problem is would be greatly appreciated.

Something in the code then. Make sure you have the script manifest and everything set to use java 8.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...