Jump to content

thenevz

Members
  • Posts

    25
  • Joined

  • Last visited

  • Feedback

    100%

Everything posted by thenevz

  1. Hey Czar, loving the script so far as I stated above, but here are some errors that appeared in the logger after running it today: [ERROR][bot #1][06/04 11:03:42 PM]: Failed to wrap : class client.mYE java.lang.RuntimeException: Could not initiate wrapper : RS2Widget at org.osbot.core.api.Wrapper.wrap(dj:188) at org.osbot.rs07.api.Widgets.getWidgets(tf:81) at org.osbot.rs07.api.Chatbox.isVisible(xk:271) at org.osbot.rs07.api.Dialogues.inDialogue(vf:172) at org.osbot.rs07.api.Dialogues.isPendingOption(vf:254) at org.osbot.rs07.api.Worlds.IIIIiiiiiiII(ui:280) at org.osbot.rs07.api.Worlds.hopToP2PWorld(ui:150) at AuX.onLoop(pn:968) at org.osbot.rs07.event.ScriptExecutor$InternalExecutor.run(hj:81) at java.lang.Thread.run(Unknown Source) [ERROR][bot #1][06/04 11:03:42 PM]: Failed to wrap : class client.mYE java.lang.RuntimeException: Could not initiate wrapper : RS2Widget at org.osbot.core.api.Wrapper.wrap(dj:188) at org.osbot.rs07.api.Widgets.getWidgets(tf:81) at org.osbot.rs07.api.Chatbox.isVisible(xk:271) at org.osbot.rs07.api.Dialogues.inDialogue(vf:172) at org.osbot.rs07.api.Dialogues.isPendingOption(vf:254) at org.osbot.rs07.api.Worlds.IIIIiiiiiiII(ui:280) at org.osbot.rs07.api.Worlds.hopToP2PWorld(ui:150) at AuX.onLoop(pn:968) at org.osbot.rs07.event.ScriptExecutor$InternalExecutor.run(hj:81) at java.lang.Thread.run(Unknown Source) [ERROR][bot #1][06/04 11:03:42 PM]: Failed to wrap : class client.mYE java.lang.RuntimeException: Could not initiate wrapper : RS2Widget at org.osbot.core.api.Wrapper.wrap(dj:188) at org.osbot.rs07.api.Widgets.getWidgets(tf:81) at org.osbot.rs07.api.Chatbox.isVisible(xk:271) at org.osbot.rs07.api.Dialogues.inDialogue(vf:172) at org.osbot.rs07.api.Dialogues.isPendingOption(vf:254) at org.osbot.rs07.api.Worlds.IIIIiiiiiiII(ui:280) at org.osbot.rs07.api.Worlds.hopToP2PWorld(ui:150) at AuX.onLoop(pn:968) at org.osbot.rs07.event.ScriptExecutor$InternalExecutor.run(hj:81) at java.lang.Thread.run(Unknown Source) [ERROR][bot #1][06/04 11:03:42 PM]: Failed to wrap : class client.mYE java.lang.RuntimeException: Could not initiate wrapper : RS2Widget at org.osbot.core.api.Wrapper.wrap(dj:188) at org.osbot.rs07.api.Widgets.getWidgets(tf:81) at org.osbot.rs07.api.Chatbox.isVisible(xk:271) at org.osbot.rs07.api.Dialogues.inDialogue(vf:172) at org.osbot.rs07.api.Dialogues.isPendingOption(vf:254) at org.osbot.rs07.api.Worlds.IIIIiiiiiiII(ui:280) at org.osbot.rs07.api.Worlds.hopToP2PWorld(ui:150) at AuX.onLoop(pn:968) at org.osbot.rs07.event.ScriptExecutor$InternalExecutor.run(hj:81) at java.lang.Thread.run(Unknown Source) [ERROR][bot #1][06/04 11:03:42 PM]: Error in script executor! java.lang.NullPointerException at org.osbot.rs07.api.Chatbox.IiiiiiiIIiII(xk:170) at java.util.stream.ReferencePipeline$2$1.accept(Unknown Source) at java.util.Spliterators$ArraySpliterator.tryAdvance(Unknown Source) at java.util.stream.ReferencePipeline.forEachWithCancel(Unknown Source) at java.util.stream.AbstractPipeline.copyIntoWithCancel(Unknown Source) at java.util.stream.AbstractPipeline.copyInto(Unknown Source) at java.util.stream.AbstractPipeline.wrapAndCopyInto(Unknown Source) at java.util.stream.FindOps$FindOp.evaluateSequential(Unknown Source) at java.util.stream.AbstractPipeline.evaluate(Unknown Source) at java.util.stream.ReferencePipeline.findFirst(Unknown Source) at org.osbot.rs07.api.Chatbox.isVisible(xk:170) at org.osbot.rs07.api.Dialogues.inDialogue(vf:172) at org.osbot.rs07.api.Dialogues.isPendingOption(vf:254) at org.osbot.rs07.api.Worlds.IIIIiiiiiiII(ui:280) at org.osbot.rs07.api.Worlds.hopToP2PWorld(ui:150) at AuX.onLoop(pn:968) at org.osbot.rs07.event.ScriptExecutor$InternalExecutor.run(hj:81) at java.lang.Thread.run(Unknown Source)
  2. [DEBUG][06/03 11:32:08 PM]: OSBot is now ready! [iNFO][06/03 11:32:09 PM]: Loaded 4 RS accounts! [iNFO][06/03 11:32:10 PM]: Welcome to OSBot 2.4.59! [iNFO][06/03 11:32:18 PM]: Updated injection hooks for client revision : 115! [DEBUG][bot #1][06/03 11:32:18 PM]: Initializing mirror client bot... [ERROR][06/03 11:32:18 PM]: Uncaught exception! java.lang.NoClassDefFoundError: org/osbot/rs07/accessor/XGameSettings at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Unknown Source) at java.lang.Class.getDeclaredMethod(Unknown Source) at java.awt.Component.isCoalesceEventsOverriden(Unknown Source) at java.awt.Component.access$500(Unknown Source) at java.awt.Component$3.run(Unknown Source) at java.awt.Component$3.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.awt.Component.checkCoalescing(Unknown Source) at java.awt.Component.<init>(Unknown Source) at java.awt.Container.<init>(Unknown Source) at java.awt.Panel.<init>(Unknown Source) at java.awt.Panel.<init>(Unknown Source) at java.applet.Applet.<init>(Unknown Source) at client.emu.EmuClient.<init>(Unknown Source) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) at java.lang.reflect.Constructor.newInstance(Unknown Source) at java.lang.Class.newInstance(Unknown Source) at org.osbot.rs07.Bot.initialize(jk:659) at org.osbot.bb.run(bt:209) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: java.lang.ClassNotFoundException: org.osbot.rs07.accessor.XGameSettings at java.lang.ClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at org.osbot.R.loadClass(zx:221) ... 25 more Happens every time I try to open up a client in mirror mode, havent tried stealth injection so not sure if that's working or not.
  3. Bought the script yesterday, it's flawless. Great work.
  4. Okay, it seems like sand crabs are the consensus then. As a side note, I'm 10000000000% deadset on keeping the strength at 17 for my own reasons.
  5. Thanks a bunch for the responses, all input is very much appreciated. I'll give it a shot in a bit.
  6. Ok, thanks for the idea! I'll check it out at some point to compare the exp rates. Appreciate the response!
  7. Right now i'm training at crabs and getting ~13K exp an hour, would monks be better than that?
  8. https://gyazo.com/b1f45fb0e8c81370209120242e3fc878 dont ask why my stats are the way they are looking to train to 80 defence with these current stats (att 40 and str 17) What's my best option for xp per hour? (inb4 "leveling strength") edit: im using best in slot equipment for all equips
  9. Gonna wait a few days, see if anyone offers more. Thanks for the offer, though!
  10. Looking for 40m OSRS, will be using a middleman.
  11. thenevz

    Quick Question

    Great - Thanks!
  12. Damn, ran it for about 7 hours on two of my accounts yesterday and got banned this morning. Edit: both got banned, perm bans
  13. thenevz

    Quick Question

    Thanks for the reply - if a mod could confirm or deny this and delete the thread afterwards, I would very much appreciate it.
  14. thenevz

    Quick Question

    Please delete this thread. Question has been answered.
  15. I'd like a trial please
×
×
  • Create New...