Jump to content
HeroicRambo

Bug report: Mirror client lag spikes & freeze

Recommended Posts

Hi,


I've been using the mirror client since the last update but it just won't run smoothly. It has short lag spikes and will freeze after about 30 minutes of running. My guess is that there is a memory leak in it, the memory usage starts on 84 MB and will increase untill 494 MB where it will crash after a few minutes.


 


I ran the script DarkMiner(this happens with any script), no hooks failed and I'm using 64 bit java.


 


In the console the only thing exceptional is that it prints 'Edge detect (#) thinks were having issues...', that's pretty much it.


The client crashes when the console prints 'Could not find a random tile!'.


GQI39QJ.png


 


My PC


LX6BnRR.png


 


GPU: MSI R9 280 3GB


 


If I missed something just tell me, I want to get this fixed.


Edited by HeroicRambo
Link to comment
Share on other sites

 

 

If I missed something just tell me, I want to get this fixed.

 

Those console things are nothing to do with this problem, just walker debugs :)

Problem is partially the amount of ram you're allocating and the amount of ram the mirror uses when it passes between regions.

I find allocating 1100 seems to not crash but the client jumps between 500-600mb of ram for me.

Unfortunately it just uses alot for now.

Link to comment
Share on other sites

im vip but cant get into mirrorclient says i have to download it i downloaded the new mirror client 10 times... some help

 

Put the mirror client in C:/ -> users -> username -> OSBot -> Data and run it again.

 

 

 

Alot of scripts won't function properly on the mirror client because it's a tad slow, because of the memory leak it will still crash just slower if you put it to 1GB. Hope this gets fixed smile.png

Edited by HeroicRambo
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...