Jump to content
Gnomedesto

Eclipse Error (Java related)

Recommended Posts

Since using mirror, I had to delete all but one Java. Naturally, Eclipse doesn't work anymore. Pardon my ignorance to this topic.

 

I must have the wrong Eclipse for my Java. It says it requires Java 1.6 . I'd like to keep my current Java version and only 1 version of Java on my windows. I don't know which Eclipse to download to work with my Java 8 UPdate 40.

 

I had downloaded this Eclipse version (following APA's guide, the first link) http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/kepler/SR2/eclipse-standard-kepler-SR2-win32-x86_64.zip

 

I want to use Eclipse with my current Java 8 update 40. Here's a pic that should give you all the details. It shows me following APA's guide in the middle, my version of java on the top right, the error on the bottom right, and my computer specs ( 64 bit windows 7 ).

 

Can anyone help me with this issue? I'll be hanging around this post until it's fixed. Thank you for your help.

 

2eezw34.jpg

 

Include instruction, thx!

Edited by boatsb4hose
Link to comment
Share on other sites

If I remember correctly Kelper doesn't even have native support for Java 8... I don't really understand the issue, why not just use the latest version of Eclipse?

 

https://eclipse.org/downloads/packages/release/Luna/SR2

 

Click "Eclipse IDE for Java Developers" then on the right hand side it should show a bunch of downloads for your computer type, so just click the one that matches with your hardware.

 

 

EDIT: I just looked at the picture you presented more in depth, I had the same issue awhile back (although you should still download Eclipse Luna if you want Java 8 support...) the issue has do with your environment variables.

 

 
For me the solution was to go into (on Windows 8.1):
System > Advanced system setting > Environment Variables
Under 'System variables' in the 'Path' variable there was the following first:
C:\ProgramData\Oracle\Java\javapath;
I removed this and Eclipse worked again!

 

 

This might happen if you have several versions of java in the same machine, to fix this i did the following:
Checked current JAVA_HOME value, in Windows echo %JAVA_HOME%
Accessed the route of javaw.exe
Replaced the shortcuts pointing to java home location.

 

http://stackoverflow.com/questions/11461607/cant-start-eclipse-java-was-started-but-returned-exit-code-13

 

Personally the second solution worked for me, my path to Java was wrong.

Edited by lare96
Link to comment
Share on other sites

AHA, I think that may be it. I don't have a JDK anymore. Can I download a JDK without it interfering with OSBot's "only 1 java downloaded" requirement or w/e? So should I download the latest JDK relative to my OS?

Nope, you should be good :). I have the most recent java and Jdk and everything works

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...