Jump to content

osbot can't find my local scripts and some sdn


Recommended Posts


appreciate any suggestions if you can help figure this out. 

bit of background.. this is running headless on a server using -allow nointerface in a docker container. 

so far only osMiner & f2p hill giants has worked,  khals woodcutter worked for a bit on the server itself but before and since that time bot cant locate the .properties file, and other scripts with CLI havent really worked. My own scripts are not able to be found, played around with various places to put the script, names,  files and permissions, nada. 

this is how I'm naming it usually

picture of the filestructure



java -jar /usr/share/OSBot/osbot.jar -debug 5007 -allow nointerface -login usr:pw.123 -bot bot@gmail.com:botpw:1234 -script jakesbird:null -world 347 cat /proc/$(ps aux | grep "/usr/share/OSBot/osbot.jar" | grep -v grep -m 1 | awk '{print $2}')/fd/1




package script;

import org.osbot.rs07.script.Script;
import org.osbot.rs07.script.ScriptManifest;
import sections.*;
import util.Sleep;

@ScriptManifest(author = "jakemuell1925", name ="jakesbird", info = "Completes Tutorial Island", version=0, logo = "")
public final class TutorialIsland extends Script {





Edited by jakemuell1925
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...