Jump to content
Shmeekz

Someone who knows hardwares well look here!

Recommended Posts

Hello osbot,

Im quite confused as why my desktop can run less bots than my laptop knowing that my desktop has better specs than my laptop;

 

My desktop has a i7 7700k 4.2 ghz speed CPU but for some odd reason I can only run 11-12 bots and the CPU is at MAX! wtf?! ?

while Im running around 13-14 on my laptop, laptop has i7 6700(k?) with 2.7ghz speed but with that amount of bot it is hovering 60-70% CPU use (unless webwalking). I don't understand?

both devices has same RAM (16gb)

 

does anyone have any idea? and if you guys can recommend me a Dedicated Server spec to look into for 20-30 bots? (spec wise) (ive seen intel 2.4ghz 32gb ram or 4.2ghz 32gb ram but the cpu usage of this client confuses the fuck outta me and I have no idea what server is best to get)

Link to comment
Share on other sites

It sounds like your desktop has other programs using a large portion of your processing power. If you want to run 10+ bots at a time you should configure your OS to run only what is required by OSBot and nothing else.

There is a lot of potential differences in the configuration of your two machines. I would recommend comparing power settings, services and startup programs between your laptop and PC as a start.

All of that said, your CPU and RAM are only parts of what makes a machine run well. Things like drive read/write speed, power supply, drivers, and general config can be just as, if not more, important.

I'd recommend reducing the amount of programs you run on startup as a start. Assuming you're running Win10 you can do that in the Task Manager. Then go to add/remove programs and just uninstall everything you don't use (be careful not to remove stuff like Java and .NET Runtimes). If you don't check often, you'll be surprised by how many things are eating up your resources.

Link to comment
Share on other sites

24 minutes ago, Shmeekz said:

Hello osbot,

Im quite confused as why my desktop can run less bots than my laptop knowing that my desktop has better specs than my laptop;

 

My desktop has a i7 7700k 4.2 ghz speed CPU but for some odd reason I can only run 11-12 bots and the CPU is at MAX! wtf?! ?

while Im running around 13-14 on my laptop, laptop has i7 6700(k?) with 2.7ghz speed but with that amount of bot it is hovering 60-70% CPU use (unless webwalking). I don't understand?

both devices has same RAM (16gb)

 

does anyone have any idea? and if you guys can recommend me a Dedicated Server spec to look into for 20-30 bots? (spec wise) (ive seen intel 2.4ghz 32gb ram or 4.2ghz 32gb ram but the cpu usage of this client confuses the fuck outta me and I have no idea what server is best to get)

I personally own a dual E5-2670, and a dual X5660 system. On the E5 system, I run 50 bots with around 40% cpu usage, and 40 on the X5660 system with around 45% CPU usage. You can rent dedicated servers with either of these CPU setups. I purchased my dual E5 setup for $325 and the X5660 system for $160. Neither are rack servers, they use normal sized ATX cases, have Hyper 212+ on the E5's and Arctic Freezer Pros on the X5660s. Everything is quiet and electric is cheap where I'm at so this is why I own my own and don't use VPS/Dedi servers.

Link to comment
Share on other sites

1 hour ago, Duhstin said:

I personally own a dual E5-2670, and a dual X5660 system. On the E5 system, I run 50 bots with around 40% cpu usage, and 40 on the X5660 system with around 45% CPU usage. You can rent dedicated servers with either of these CPU setups. I purchased my dual E5 setup for $325 and the X5660 system for $160. Neither are rack servers, they use normal sized ATX cases, have Hyper 212+ on the E5's and Arctic Freezer Pros on the X5660s. Everything is quiet and electric is cheap where I'm at so this is why I own my own and don't use VPS/Dedi servers.

Hey bro, thats interesting that you build your own server; do you mind if I add you on discord and maybe educate me more on this? haha

1 hour ago, Dot said:

It sounds like your desktop has other programs using a large portion of your processing power. If you want to run 10+ bots at a time you should configure your OS to run only what is required by OSBot and nothing else.

There is a lot of potential differences in the configuration of your two machines. I would recommend comparing power settings, services and startup programs between your laptop and PC as a start.

All of that said, your CPU and RAM are only parts of what makes a machine run well. Things like drive read/write speed, power supply, drivers, and general config can be just as, if not more, important.

I'd recommend reducing the amount of programs you run on startup as a start. Assuming you're running Win10 you can do that in the Task Manager. Then go to add/remove programs and just uninstall everything you don't use (be careful not to remove stuff like Java and .NET Runtimes). If you don't check often, you'll be surprised by how many things are eating up your resources.

- Hey bro, I actually am aware of the programs running in the background, ive restarted my pc before running my farm and on startup without any bots running; Im at low %5 CPU usage as well as RAM
, logging in a user with not much start up programs...
but thanks for giving the tips of looking at other configs like battery usage settings and etc; will look into it!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...