Jump to content
mutedhue

Issue Initializing Mirror bot - Uncaught Exception!

Recommended Posts

Apologies if this is a simple fix, however I've spent some time searching the forum and couldn't find anything. 
 

I have botted successfully using OSBot previously, however I recently bought VIP to try Mirror mode and haven't been able to get it working. These are the steps I have been taking:

1. Run official OSRS client / OSBuddy (tried both, even after a fresh machine restart). Client is now sitting on log on screen.

2. Run instance of OSBot, log in using Mirror Mode. At this stage the debug logger states the following

Quote

[DEBUG][04/28 08:03:22 PM]: OSBot is now ready!
[INFO][04/28 08:03:23 PM]: Loaded 3 RS accounts!
[INFO][04/28 08:03:25 PM]: Welcome to OSBot 2.4.121!

iB2nNix.png

3. Click add bot, select my account. As soon as I hit "continue," the debug logger displays the following:

Quote

INFO][04/28 08:07:37 PM]: Updated injection hooks for client revision : 140!
[DEBUG][Bot #1][04/28 08:07:37 PM]: Initializing mirror client bot...
[ERROR][04/28 08:07:37 PM]: Uncaught exception!
java.lang.NoClassDefFoundError: dt
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
    at java.lang.Class.getDeclaredMethod(Unknown Source)
    at java.awt.Component.isCoalesceEventsOverriden(Unknown Source)
    at java.awt.Component.access$500(Unknown Source)
    at java.awt.Component$3.run(Unknown Source)
    at java.awt.Component$3.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.awt.Component.checkCoalescing(Unknown Source)
    at java.awt.Component.<init>(Unknown Source)
    at java.awt.Container.<init>(Unknown Source)
    at java.awt.Panel.<init>(Unknown Source)
    at java.awt.Panel.<init>(Unknown Source)
    at java.applet.Applet.<init>(Unknown Source)
    at client.emu.EmuClient.<init>(Unknown Source)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at org.osbot.rs07.Bot.initialize(li:463)
    at org.osbot.oD.run(zab:11)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: dt
    at java.lang.ClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at org.osbot.LA.loadClass(pab:75)
    ... 25 more
 

09uUycD.png

 

I'm using Windows 8.1 pro / Java 8 Update 131. As I mentioned, I have tried both official OSRS client and OSbuddy. Have tried low CPU mode and fixed screen mode, doing a fresh restart of my machine each time with no luck. Any advice is greatly appreciated. Cheers.

 

  • Like 1
Link to comment
Share on other sites



  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...