Jump to content

CLI -world flag isn't working


PlumpRump
 Share

Recommended Posts

I am attempting to run scripts from the CLI in a unix environment. My bot accounts are F2P, so I need to switch the world to a F2P world in order for them to login. I have attempted to use the -world flag to accomplish this, but it doesn't work. The osbot client starts, and then instead of trying to change the world it just immediately goes to log in, fails because it's always a member's world, and then gives up. The CLI code I'm running is below.

java -jar [my osbot jar] -login [my osbot username]:[my osbot pass] -bot [bot email]:[bot pass]:0000 -script [my script]:null -world 301

As you can see, I include the "-world 301" flag at the end. I have managed to pause the script before it tries to log in and changed the world to a F2P one and then it logs in successfully.

Edit: I should also mention I'm using osbot 2.5.42.jar

Edited by PlumpRump
Link to comment
Share on other sites

  • 4 months later...
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...